Forum Messages

Forum Home Page

Date Name Message
23/09/2005 11:08:01   Rens   I've installed an electronic ignition and a new coil, but now i don't get a spark...
I measured the voltages. At the coil i get 24 volt when ignition is on. and at the end of that wire i still have 24.. and inside the cap it's still 24... but it doesn't seem to transfer the voltage to the points inside the cap so there is no voltage at the spark plug...

I tried to rewire everything, tried all the different ways with the wires, but still no electricitie at the spark plug.

Any ideas of what i'm doing wrong? i can take pictures of the setup if needed!  
23/09/2005 12:49:51   Richard   What system are you using? Sounds like something is not triggering. If its a lumi. set up you can remove the breaker and run a bit of card through it to test its firing on a meter. Have you got the correct chopper if its an optical system. Otherwise is there a problem with the rotor arm?  
24/09/2005 12:37:39   Senor Burt   Search Google for 'pertronix troubleshooting' I found several useful pages.  
24/09/2005 15:43:35   Derek   Have a look at the "Aldon" points instalation in the "Articles" here on site. Aldon/Ignitor same unit. Try your using original coil. I believe there can be problems matching the Flamethrower coil to the Ignitor. You may already have blown-up the Ignitor module but if it works with the original coil you can breathe a sigh of relief. Flamethrower coil not needed anyway.
Anyone have any ideas on the 24volt readings?  
24/09/2005 16:07:17   Rens   Looked at the article, even used it when installing!

but what is this? problems with matching the flamethrower coil with the ignition??? the adviced me to buy this one with the kit!

i'll try the original coil, hope i didn't blew it up already, would be an expensive mistake...

Another stange thing is that i have a Postive 12 volt reading on the postive site of the coil, but also a postive 12 volt reading on the negative site of the coil.. is this normal??  
24/09/2005 20:45:25   Derek   The plot thickens.... Can't help you with the voltages I'm afraid. Is your engine a 1.7l? Only saying that as in your pics the dizzy seems to timed a lot different to mine and the one in the Aldon pics. Mine and his have the vacuum module positioned approx with the seam inline with the crank. i.e. fore and aft. Your rotor also seems rather high too as if the magnet ring hasn't gone down far enough. Note the magnet position relative the shaft cut-out in the Aldon pic.
Yes I'm clutching at straws too......
Good luck  
27/09/2005 12:27:42   Rens   any one an idea about the voltage readings?  
28/09/2005 21:51:01   Alex   It's a bit difficult to judge the position of the rotor arm on the photo but it looks as if the bottom is just a bit below the top of the sensor, which should be ok; I just checked mine and it is positioned the same way. However, the photo looks as if the magnet ring is missing, or is this optical illusion caused by the flash?  
29/09/2005 07:51:08   Rens   it's an optical illusion caused by the flash... i can see it :)  
29/09/2005 13:02:25   Richard   I would contact the manufacturer they will probably sort you out.  
30/09/2005 11:19:12   Alex   Any result with using the old coil yet?  
03/10/2005 09:31:43   Rens   not tried old coil yet, i'm still working on it, got some extra hands to help me out! and i emailed the companie where i bought it  


Post Reply

Name
E-Mail
Reply