SAAB V4 Forum
SAAB V4 Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Technical
 General Technical
 Turn honk turn honk
 New Topic  Reply to Topic 
 Printer Friendly 
AuthorPrevious Topic Topic Next Topic 

john-saab
Administrator

United Kingdom
2665 Posts

Posted - 03 Feb 2018 :  08:31:04 Show Profile Reply with Quote
Odd one on my 96. When I turn the steering wheel the horn sounds by it's self. It only did it on full lock so I removed the steering wheel, inspected everything and couldn't see anything obvious..put it back together and it now honks 2-3 times PER TURN..very embarrassing when trying to get off my drive etc. There doesn't seem to be a "sweet spot" that does it every time.
When the steering wheel was off I inspected the wiring and it looked good, the contact ring flat and clean, the brass contact pin free moving and it's housing secure.
Suggestions please as the quick fix was to remove the horn fuse.

'73 96 (Vernon),'74 95 (Veronica)plus 4 other 95's and 2 96's

chris steeden
V4 Beginner

United Kingdom
73 Posts

Posted - 03 Feb 2018 :  09:31:07 Show Profile Reply with Quote
If your horn ring is an early one (pre 67 I think) it can only be one of two things John. The horn circuit is permanent live to the horns then coupled up return feed from the horns (Neutral) back through the bulkhead, up the steering column via a small hole in the shaft and then the (N) earths out via the horn button. Check that the cable hasn't cracked or chaffed near the shaft hole thus earthing out when you turn the wheel or if okay double check the push on spade under the horn button (it may have a loose strand of wire earthing out). last thoughts is that the horn plate and Bakelite disc are misaligned or touching the spring (the end of the spring should fit in a small hole in the Bakelite disc and the other end of the spring in the metal cup and this also seats only in one position from memory).
If you refer to a late horn ring (1970-) could it be that the pad has been tightened too tightly (4 screws under pad) which may have misaligned or bent the horn contact plate located under the pad and which these 4 screws push through and thread into said pad. This in http://home.bt.com/#turn would activate the sliding contact which the negative/earth wire fixes to.

Edited by - chris steeden on 03 Feb 2018 22:51:21
Go to Top of Page

chris steeden
V4 Beginner

United Kingdom
73 Posts

Posted - 03 Feb 2018 :  22:55:11 Show Profile Reply with Quote
[quote]Originally posted by chris steeden
If your horn ring is an early one (pre 67 I think) it can only be one of two things John. The horn circuit is permanent live to the horns then coupled up return feed from the horns (Neutral) back through the bulkhead, up the steering column via a small hole in the shaft and then the (N) earths out via the horn button. Check that the cable hasn't cracked or chaffed near the shaft hole thus earthing out when you turn the wheel or if okay double check the push on spade under the horn button (it may have a loose strand of wire earthing out). last thoughts is that the horn plate and Bakelite disc are misaligned or touching the spring (the end of the spring should fit in a small hole in the Bakelite disc and the other end of the spring in the metal cup and this also seats only in one position from memory).
If you refer to a late horn ring (1970-) could it be that the pad has been tightened too tightly (4 screws under pad) which may have misaligned or bent the horn contact plate located under the pad and which these 4 screws push through and thread into said pad. This in turn would activate the sliding contact which the negative/earth wire fixes to. Last thought, can this contact plate be fitted upside down or back to front? and/or is the sliding contact located correctly?

OOPS! Looks like the 'EDIT' controls are up the swanny

Edited by - chris steeden on 03 Feb 2018 22:57:44
Go to Top of Page

john-saab
Administrator

United Kingdom
2665 Posts

Posted - 04 Feb 2018 :  08:23:54 Show Profile Reply with Quote
Later horn Chris...1974 car. I will try to have another look today and report back.

'73 96 (Vernon),'74 95 (Veronica)plus 4 other 95's and 2 96's
Go to Top of Page

v4admin
Forum Admin

United Kingdom
391 Posts

Posted - 04 Feb 2018 :  13:32:12 Show Profile Visit v4admin's Homepage Reply with Quote
I had this on mine years ago and it was the wire running up through the column had worn through and earthing on the surround.
Go to Top of Page

Dirtbiker
V4 Mad

United Kingdom
606 Posts

Posted - 04 Feb 2018 :  20:51:22 Show Profile Visit Dirtbiker's Homepage Reply with Quote
Hi John,
Same as above, the wire on mine had worn through behind that metal cover on the underside of the column. IIRC I spent a happy afternoon sorting it out on Treen campsite in right at the bottom of Cornwall...
Cheers
Go to Top of Page

Dirtbiker
V4 Mad

United Kingdom
606 Posts

Posted - 04 Feb 2018 :  20:53:27 Show Profile Visit Dirtbiker's Homepage Reply with Quote
ps. Saw the 95 in Practical Classics, if you ever decide you're not going to get around to it just let me know...
Go to Top of Page

pchristy
V4 Guru

United Kingdom
1763 Posts

Posted - 10 Feb 2018 :  14:02:24 Show Profile Reply with Quote
John,

My original '69 car had the horn on the wiper stalk - where the washers are on the later cars (pull the stalk). I had the same problem as you on the white 95 briefly, and on investigation, found that the old horn wire still existed in the wiring loom to the washer stalk, even though it was no longer connected. This spare wire had got damaged at some point, and was shorting to earth when you turned the wheel, thus sounding the horn!

If you can't find the problem in the horn push on the steering wheel, have a look around the wiper stalk!

--
Pete
"Duct tape is like the Force: It has a light side and a dark side, and it binds the Universe together!"

Edited by - pchristy on 10 Feb 2018 14:03:01
Go to Top of Page

pchristy
V4 Guru

United Kingdom
1763 Posts

Posted - 21 Feb 2018 :  09:56:30 Show Profile Reply with Quote
Did you ever get to the bottom of this, John?

--
Pete
"Duct tape is like the Force: It has a light side and a dark side, and it binds the Universe together!"
Go to Top of Page
 Previous Topic Topic Next Topic 
 New Topic  Reply to Topic 
 Printer Friendly 
Jump To: 
Snitz Forums 2000
SAAB V4 Forum© 2000-04 Snitz CommunicationsGo To Top Of Page